Crafting from the Forge is failing.
Incident Report for Pirate Nation
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 23:45 UTC
Identified
Transactions triggered by crafting items in the Forge are failing. The team is aware of the issue and will push a fix ASAP.
Posted Nov 14, 2024 - 23:21 UTC
This incident affected: Game Client.